Actualiza a Wordpress 4.5.2

WordPress 4.5.2, la actualización crítica que debes instalar ahora

Se ha publicado WordPress 4.5.2, una actualización crítica que debes instalarte de forma inmediata.

El pasado día 18 de Abril te hablaba de la nueva versión de WordPress 4.5, que incluía algunas mejoras significativas para tu web o blog.

Posteriormente se han publicado dos actualizaciones más: 4.5.1 y 4.5.2.

En este post voy a comentarte de qué van estas dos nuevas actualizaciones y por qué debes instalártelas urgentemente, sobretodo la 4.5.2

La nuevas actualizaciones de WordPress 4.5

Tras la actualización de WordPress 4.5 se detectaron algunos problemas de compatibilidad con algunos plugins y temas.

Es muy habitual que los mismos usuarios reporten estas cuestiones a la compañía para solucionarlas.

Así que se liberó la versión 4.5.1 para solucionar estos problemas

WordPress 4.5.1

Pocos días después del lanzamiento de WordPress 4.5, se liberaba 4.5.1.

Esta nueva actualización soluciona hasta 12 errores que se habían localizado.

Quizás el más importante sean  las correcciones para el tema Twenty Eleven, el cual daba problemas con algunas versiones de Chrome y el editor visual de WordPress.

Otro problema destacado que se soluciona con esta versión se refiere a Imagick (una extensión PHP para crear y modificar imágenes. Puedes ver más información en la siguiente URL: http://www.desarrolloweb.com/articulos/intro-imagick-php.html).

El problema era que hacía imposible la carga de archivos multimedia como imágenes o vídeos.

Otros errores que se solucionan en esta versión los encontrarás en este link:

https://core.trac.wordpress.org/log/branches/4.5?rev=37295&stop_rev=37182

Así que al actualizarte a WordPress 4.5.1 se te solucionan muchos problemas de compatibilidad que se habían detectado en esta versión

Por qué debes actualizarte a WordPress 4.5.2 ahora mismo

Hace escasamente 3 días que se ha liberado la versión 4.5.2, a la que llamo crítica por lo necesario de su actualización.

Según ha publicado WordPress.org en su artículo “WordPress 4.5.2, actualización de seguridad”, parece ser que se han detectado graves problemas de seguridad en esta versión del CMS que se solucionan con esta actualización.

Parece ser que todas las versiones anteriores de WordPress sufren un agujero de seguridad en una librería externa de subida de archivos llamada Plupload.

Y también parece que este problema se remonta a la versión 4.2 y lo hace vulnerable a un ataque de XSS reflejo si se utilizan URLs creadas con la librería MediaElements.js.

En esta versión se han actualizado tanto MediaElements.js como Plupload para corregir esta brecha de seguridad, por lo que podrás estar un poco más tranquilo en lo que respecta a seguridad de tu WordPress.

Conclusión

Como puedes ver, actualizarte a WordPress 4.5.2 ya no es una opción para tu web o blog.

Te recomiendo que leas el artículo “¿Te conviene actualizar a WordPress 4.5? donde te explico los pormenores de esta nueva versión de WordPress, por qué y cómo actualizar tu web de forma segura y sin problemas de compatibilidad.

Si tienes más información sobre esta nueva versión de WordPress, te animo a que la cuentes en los comentarios.

4 comentarios
  1. Marta
    Marta Dice:

    No sabia que era tan importante actualizar. ¿Hay alguna otra manera de estar al dia sin actualizar? Una vez lo hice y me dió problemas la web y dejó de funcionar

    Responder
  2. Daniel
    Daniel Dice:

    Hola Luis. ¿Sabes que tengo la actualización pero me sigue dando errores el WordPress?
    Cuando voy a subir un post o cuando voy a poner un código html en uno de los widget no me actualiza, por tanto, los cambios no ocurren.
    Realmente, estoy complicado con mi wordpress.

    ¿Hay alguna solución? Gracias por tu ayuda, Daniel.

    Responder
    • Luis A. Román Mañas
      Luis A. Román Mañas Dice:

      Hola Daniel. Gracias por tu comentario.
      Por lo que yo sé, se están produciendo problemas de compatibilidad con algunos plugins y temas tras la actualización.
      Por ejemplo, se ha publicado que lo está dando problema:
      Plugins
      Divi Builder
      Visual Composer
      Custom Facebook Feeds
      JetPack
      Free Shorcode Accordion Builder for WordPress
      a3 Lazy Load
      HeadSpace2 SEO
      Beaver Builder
      LearnPress

      Themes
      Divi Theme
      Algunos temas de ThemeForest

      Pero en todos los casos se soluciona actualizando dicho plugin o Theme.
      Yo te aconsejo lo siguiente:

      -Asegúrate de no tener ninguno de estos plugins o temas.
      -Desactiva todos los plugins y cambia el tema por uno de los que lleva por defecto WordPress
      -Prueba a hacer los cambios que querías y confirma que va bien. Si no es así, el problema viene de otro sitio
      -Una vez confirmado que ahora sí va bien, ves activando uno por uno los plugins para localizar cual es que te crea el problema.
      -Una vez localizado, sustitúyelo por otro que sepas que funciona bien con la actualización.

      Haz lo mismo con el tema.
      Ya me contarás que tal te ha ido.

      Un saludo

      Responder

Dejar un comentario

¿Quieres unirte a la conversación?
Siéntete libre de contribuir

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *