¿Problemas con Gutenberg en WordPress 5? ¡Desactívalo!

Comparte este artículo

Desde la última gran actualización de WordPress y la inclusión de su nuevo editor visual Gutenberg, son muchos los usuarios que se están quejando de incompatibilidades con sus editores visuales como Visual Composer o Page Builder.

Hoy veremos como solucionar estos problemas…¡y de forma superfácil!.

Wordpress 5 problemas con gutenberg

¿Nos hemos precipitado actualizando a WordPress 5?

En principio, yo diría que no.

WordPress 5 trae múltiples novedades en esta versión, entre las que destaco:

  • Mejoras de seguridad.
  • Compatible con PHP 7.3.
  • Mejoras en el theme Twenty nineteen, especialmente en cuestiones responsive.
  • Mejoras para el desarrollo de themes personalizados.
  • Mejoras en la gestiones de imágenes de fondo.
  • Mejoras para generar avisos como mensajes emergentes.
  • Y, por supuesto, el nuevo editor por bloques Gutenberg

Es evidente que sólo por las mejoras en seguridad, compatibilidad con la última versión de PHP, a nivel de optimización y diseño de themes ya es conveniente actualizar.

[Tweet «La realidad es que Gutenberg ha traído bastantes problemas»]

Entonces… ¿El problema es sólo con Gutenberg?

Gutenberg, el nuevo editor por bloques de WordPress 5

Pues a grandes rasgos hay que decir que sí.

La realidad es que Gutenberg ha traído bastantes problemas, y es normal…

Estábamos acostumbrados a trabajar de una manera determinada y este nuevo editor cambia totalmente la filosofía de trabajo.

Decía M. Carmen de Alba (experta en usabilidad) que a este editor aún le queda mucho trabajo por hacer, y en su artículo: «Usabilidad web: Problemas con el editor Gutenberg» detalla algunos de los problemas que localiza al usar este editor.

Si a estos problemas de usabilidad le sumamos los problemas de compatibilidad con muchos editores visuales, el cambio a WordPress 5 puede estar siendo una pesadilla para muchos usuarios, sobretodo para los menos avanzados o técnicos, ya que no encuentran una solución fácil para este problema…

Pero la realidad es muy distinta: La solución es facilísima.

[Tweet «»Classic Editor» es un plugin que puede restaurar tu antiguo editor»]

La solución a todos tus problemas está en un sólo plugin.

Pues sí, como decía mi abuela, «todo en esta vida tiene solución» y la tuya se llama «Classic Editor«

«Classic Editor» es un plugin que puede restaurar tu antiguo editor y así eliminar todas las incompatibilidades que aparecen con Gutenberg.

Tanto es así, que incluso desde WordPress recomiendan usarlo como elemento de transición para la nueva versión.

¿Cómo instalar «Classic Editor» en WordPress 5?

Por suerte el plugin «Classic Editor» lo puedes encontrar en el repositorio de WordPress por lo que la instalación es tan sencilla como instalar cualquier otro plugin.

Instalar Classic Editor

Los pasos que has de seguir son los siguientes:

  1. En tu menú de WordPress ves a «plugins» o «Complementos»
  2. Clicka en «Añadir nuevo».
  3. En el campo «Buscar plugin» escribe «Classic Editor» o «Editor Clásico» y te saldrá el primero.
  4. Pulsa en el botón «Instalar ahora».
  5. Una vez instalado, pulsa en «Activar».
  6. Ahora puedes ir a «Settings» del plugin y allí seleccionar la que active la versión anterior del editor… y ¡¡listo!

Ahora ya puedes ir a crear una página o una entrada nueva y verás que vuelves a tener el editor clásico de WordPress… Incluso puedes ver los contenidos que tienes maquetados con un editor visual de pago. ¡Ya puedes modificarlos y que todo funcione correctamente!.

[Tweet «Gutenberg Ramp, el plugin que hace de switch entre los editores»]

¿Puedo tener los dos editores, según me convenga?

Rotundamente sí y gracias a un segundo plugin: Gutenberg Ramp.

gutenberg ramp

Este segundo plugin hace de switch para escoger dónde quieres una editor u otro, por lo que puedes tener los mejor de los dos mundos a solo un click.

Este plugin lo encontrarás en el repositorio de WordPress y su instalación también es muy sencilla.

La única configuración que necesita la encontraras en el apartado «Ajustes de Lectura«, dentro de «Ajustes» (en el menú), donde debes seleccionar «Allow users to switch editors» en «Yes» y ya lo tienes disponible.

Desactivar Gutenberg sin plugins

Hay veces que no hacen falta plugins, con un toquecito de código se soluciona.

Para desactivar Gutenberg en WordPress 5 sólo has de modificar el archivo functions.php de tu theme.

Incluye el código siguiente:

add_filter('use_block_editor_for_post', '__return_false');

Te recomiendo que trabajes con un tema hijo, si no , al actualizar, perderás esta funcionalidad.

 


Comparte este artículo